Error upgrading Wordpress 2.8.4

Wordpress is amazing... I just love it. Recently they rolled out inline upgrades, allowing you to upgrade the entire core with just a couple of clicks inside the browser. No more FTP. Anyway, the upgrade to 2.8.4 (very important) failed for me, due to the following error:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2357046 bytes) in /home/[xxxxx]/public_html/wp-includes/http.php on line 1331

The fix is pretty simple, you just need to increase the memory limit in your wp-settings.php file. Mine was 32MB, I upped it to 48MB and that was all that was needed.

Source: http://wordpress.org/support/topic/299841